Contact Me

Feel free to add a comments below, I will answer as soon as possible.

 

684 thoughts on “Contact Me

  1. Katie Harrington

    Hi! I really love your plugin and want to continue to use it.
    Unfortunately, when I click on the red ‘Add New Document’ button I get a quick view that goes away and the a black screen.
    Any ideas?
    Thanks in advance.
    I have screen shots if needed.

    Reply
    1. Bhaldie Post author

      Black screen: Try disabling all plugins to see if the problem goes away, most of these issues are due to other plugins. If that doesn’t work try going to setting and disabling Bootstrap Dashboard.

      Reply
  2. Gavin Dickson

    Since the upgrade, when I click to “Memphis Docs” in the dashboard section, a very large box opens and cannot be closed. It appears that Memphis Docs is opening and then covered with another WordPress “window” that includes cancel, exit, and ‘X’. Unfortunately, none of the links appear hot. I have check to make sure it wasn’t a theme issue or a browser issue. One thing is for sure, all worked well until the upgrade and I need to add a time sensitive document but can’t now.

    Reply
    1. Bhaldie Post author

      You could downgrade to a older version of mDocs. But my guess is that there is a plugin conflict try disabling all plugins and see if the problem goes away.

      Reply
    1. Bhaldie Post author

      More than likely a css issue, is your site public I could have a quick look at it.

      Reply
  3. CR

    Any chance you can please add the following:
    1. The search function… Exists in the settings, doesn’t seem to come up anywhere on the ‘user-view’ above the folder structure to search for a file. I’m guessing this is a bug and the search function should exist??
    2. Any way of being able to set ‘all folders’ to automatically be ‘expanded’ so that all files with a ‘main folder’ & it’s sub-folders can be shown. Currently you have to click ‘in-and-out’ of each subfolder rendering things like the ‘standard search function’ within a web browser useless, if the above isn’t possible to be fixed.

    Thanks

    Reply
    1. Bhaldie Post author

      Number 2 is a feature request already and will be out in a later version of mDocs.

      Search functionality uses WordPress builtin search, there is no mDocs specific search. What advance search does in the mDocs setting is search version, file name, name, and description.

      Reply
  4. Anna Smith

    Hiya,

    I’ve created two folders ‘Folder 1’ and ‘Folder 2’.
    Within each folder there are multiple files.

    How do I display each folder and the files within on a single page?
    Current I can only view a post page at a time i.e.
    WEBSITE URL/blog/mdocs-posts/doc-1/

    I would ideally like the URL to be:
    WEBSITE URL/blog/mdocs-posts/Folder 1
    and on the page list all the files within that folder

    Even better without the ‘Blog’ in the URL

    Reply
    1. Bhaldie Post author

      Simply use the shortcode [mdocs cat="Folder 1"] on any page or post to get your desired results.

      Reply
      1. Anna Smith

        Hiya,

        Thanks for the answer.

        I can see that you have a ‘Custom Page’ URL field which allows me to set a specific landing page once logged in.

        How can I allow certain users to land on a specific page?
        I.E
        Once Client A logs in, they see a specific page which lists the folders and documents that apply to them
        When Client B logs in, they see a specific page which lists the folders and documents that apply to them
        The pages are different for each client.

        Thanks

        Anna

        Reply
        1. Anna Smith

          The ‘Custom Link’ appears in the ‘Memphis CL’ plugin.
          Each Client needs a separate login with access to certain files. No Client will see the same files, therefore, I need a way for a Client to land on their custom page rather than a generic landing page that shows all documents.

          Reply
        2. Bhaldie Post author

          current memphis custom login doesn’t support that. You can only set one custom login page. I will add it to the feature request list. Thanks for the input.

          Reply
  5. Theo Jager

    This is the use case, when using the Frontend Upload:
    – User A uploads a Private Post via the Frontend Upload feature
    – User B with the Role “View Private Posts and Pages” wants to see the document uploaded by user A

    This are my results:
    – User A doesn’t see his own upload. Applying the additional role ‘View Private Posts and Pages’ doesn’t change his view.
    – User B doesn’t see User A’s upload.
    – a full admin user can see the Private Post

    Did I miss something?

    Reply
      1. Truijllo

        without “<a href " , I mean… I don't really need to show details about files, is there a way/setting to block the dropdown menu and to show the name without the link ?

        Reply
        1. Bhaldie Post author

          unfortunately no, the dropdown menu can not be turned off. I can add it as a feature request thou.

          Reply
          1. Truijllo

            Thank you again!
            I’m experiencing a very strange issue, the only way I have to show the dropdown is to check the bootstrap fix, the links in the dropdown are randomically clickable ( sometimes I have to click 10 times to be able to see the modal, sometimes 1 or 2 times is enough ).
            Can you help me please?
            An example page is : http://www.tdm-project.it/risultati/documenti-pubblici-2/

          2. Bhaldie Post author

            what browser are you using.. I just tried with Safari and everything works fine.

          3. Truijllo

            2 Ubuntu Linux with Chrome (the oldest is 48.0.2564.116) & Firefox ( the oldest is 49.0.2)

          4. Bhaldie Post author

            Your version of both Firefox and Chrome are extremely old, please update to the most recent version and try again.

          5. Truijllo

            I’ve tried also with an Ubuntu Linux with Chromium ( 65.0.3325.181 ) and Firefox (57.0.4) but the behaviour persist, I think there is a conflict but I can’t get it also because it is random !

          6. Bhaldie Post author

            i’ve been to your site using Safari Chrome Firefox on MacOSX all work perfectly fine. I don’t have a linux machine to test on. Change you try another OS and see if it works. It might be a ubuntu thing?

          7. Truijllo

            Maybe I fixed the behaviour but I’m not sure, I don’t have a large feedback from my users, I tried several others browsers ( updated and not, always on Linux ) but I couldn’t find a common factor.
            I unminified the JS and in the “mdocs_toggle_dropdown_menu” function I modified the delay to 500, I don’t know exactly why but it seems it works πŸ˜€
            Digging out the code I found a meaningless typo you can easily spot with grep -iR “mdocs_desciption_rights” *

          8. Bhaldie Post author

            i will add the delay 500 to the next version, and you can give me an update of how its working.

  6. Seth

    This plugin is Great!

    I am having trouble adjusting the text color of the file name. My site is using a white background and the text is showing up white in the Memphis Docs area. Is there a way I can change it from my end?

    Reply
    1. Bhaldie Post author

      its prob a css issue, is your site open to the public if so I can have a look and see what the issue might be.

      Reply
      1. Seth

        It’s not open to the public but I can generate a login for you. If you send me an email I will give you some login info

        Thanks for the reply

        Reply
    1. Bhaldie Post author

      Can you describe what you idea is please before I give out my email address, second its not that hard to find it if you look hard enough πŸ™‚

      Reply
      1. danila

        Yes it was css error
        .table>tbody>tr>td {
        width: 1px;
        }

        I updated the application and it stopped showing information about the file (version scan and so on)

        Reply
  7. alex

    Hi, thanks for the great plugin. Help me configure it correctly. I want that the page would be like yours on this site. What would be the main page already started with categories and documents. What I just did not do. I can not do it. Tell me how to make the categories on top of the list.

    Reply
    1. Bhaldie Post author

      there was a bug with version 3.8.5, the configuration menu was missing. Try downloading the newest version you should see an Options button at the top of the mdocs Dashboard page.

      Reply
  8. Ethan

    FYI, the latest release changes add_cap(‘mdocs-dashboard’) to add_cap(‘mdocs_dashboard’) in mdocs-dashboard.php, preventing the dashboard menu for showing up for me.

    Reply
    1. Bhaldie Post author

      yes, im working on a fix will have a new version out tomorrow.

      for now if you need settings add this to the end for your url: &mdocs-cat=settings

      Reply
  9. Sergiu

    Hello there,

    I have a problem with memphis docs, it shows a few modals and I can’t get pass them.
    Tried to disable most of the plugins that I have but no luck there.
    See the screenshot here: https://ibb.co/bVbHVS

    I even tried to uninstall/install again, but it seams that the database structure is the same.
    How can I permanently delete the plugin with data and try a fresh install?
    Or is something that I can do?

    The html generated message looks like this: https://ibb.co/eAHXVS

    Thanks!

    Reply
    1. Bhaldie Post author

      sounds like a javascript error or a bootstrap issue. The only way to determine what the issue is, is to disable all other plugins then enable one at a time until the problem comes back. From there let me know what plugin is causing the conflict and maybe I can fix the issue on my end.

      Reply
      1. Sergiu

        Hi,
        Well it seams LearnPress is causing the problem.
        I’ve updated to latest version of LearnPress and from there it started Memphis to have problems.
        Please take a look at this, we are using both plugins.
        Thanks!

        Reply
        1. Bhaldie Post author

          looks like LearnPress is using a Bootstrap css class called “modal” if you open the file admin.css and goto line 1394 and remove all the content in this class everything works fine:

          .modal {
          position: fixed;
          z-index: 1000000;
          width: 100%;
          height: 100%;
          top: 0;
          display: table; }

          My other suggestion would be to contact the developer of LearnPress and let them know the problem maybe that can rename there class.

          Reply
          1. Sergiu

            Thanks for the help, works like a charm. I will send LearnPress a mail and let them know.

    1. zac

      Hi again,

      I can see that the plugin is successfully installed as I can create a [mdocs] page. But… no Mdocs menu showing up.

      Reply
      1. zac

        Yes. I have updated everything as required and also tried deactivating all my otyher plugins to try and troubleshoot. Still nothing.

        Reply
        1. Bhaldie Post author

          hmm.. can you try deleting the mDocs plugin then downloading the most current version from the WordPress site and try to install it again. Also can you tell me what your apache and php error setting are set to.

          Reply
  10. Mustafa

    Hi Bhaldie,

    I translated it to 99.9% turkish. To me it was a very accurate translation.
    Can we publish the tr_TR.mo and tr_TR.po files

    Reply
  11. Jason

    I have been trying to get the Memphis Last Updated & Memphis Top Downloads widget to show the documents. What is the secret? The panel shows nothing although I have updated several files. I would also love the ability to show the most recent uploaded docs if that is possible? My site is an intranet and password protected, but I did include a test site I have below.

    Reply
    1. Bhaldie Post author

      Trying going back to the widget and saving the number of file to show in the list. Also Last Updated is the most recent uploaded file.

      Reply
  12. Jamy

    Hello,

    first of all: Thank you for the amazing plugin.

    Here is my question: I am using the free theme “MyWiki” with current WordPress 4.9.4.
    Since I installed “Memphis Documents Library”, the search bar on the start page is shortend.
    If I now move to e.g. a post or a sub site, the search bar is like expected again.

    Can you please tell me, how I can fix this?

    Kind regards,
    Jamy

    Reply
    1. Bhaldie Post author

      could you send me a link to your website, its more than likely a css problem, but if I could see what the issue is it would be easier to debug.

      Reply
      1. Jamy

        Thanks for the quick reply.
        I’m sorry, but my website isn’t public. You will only see the login screen.

        Kind regards,
        Jamy

        Reply
        1. Bhaldie Post author

          thats fine, can you send me the link to the theme you are using and I will download it and test it on my dev server.

          Reply

Leave a Reply

Your email address will not be published. Required fields are marked *